CCNA Security: chapter 9 Secure Network packet tracer activity – answer

PT Activity: Configure a Network for Secure Operation

Introduction

In this comprehensive practice activity, you will apply a combination of security measures that were introduced in the course. These measures are listed in the objectives.

In the topology, R1 is the edge outer for the Company A while R3 is the edge router for Company B. These networks are interconnected via the R2 router which represents the ISP. You will configure various security features on the routers and switches for Company A and Company B. Not all security features will be configured on R1 and R3.

Learning Objectives

  • Secure the routers with strong passwords, password encryption and a login banner.
  • Secure the console and VTY lines with passwords.
  • Configure local AAA authentication.
  • Configure SSH server.
  • Configure router for syslog.
  • Configure router for NTP.
  • Secure the router against login attacks.
  • Configure CBAC and ZPF firewalls.
  • Secure network switches.

 

Task 1:      Test Connectivity and Verify Configurations

Step 1.      Verify IP addresses.

Step 2.      Verify routing tables.

Step 3.      Test connectivity.

From PC-A, ping PC-C at IP address 192.168.3.5.

Task 2:      Secure the Routers

Step 1.      Set minimum a password length of 10 characters on router R1 and R3.

 

R1(config)#security passwords min-length 10

 

Step 2.      Configure an enable secret password on router R1 and R3.

Use an enable secret password of ciscoenpa55.

R1(config)#enable secret ciscoenpa55

Step 3.      Encrypt plaintext passwords.

 

R1(config)#service password-encryption

 

Step 4.      Configure the console lines on R1 and R3.

Configure a console password of ciscoconpa55 and enable login. Set the exec-timeout to log out after 5 minutes of inactivity. Prevent console messages from interrupting command entry.

R1(config-line)#password ciscoconpa55

R1(config-line)#login

R1(config-line)#exec-timeout 5

R1(config-line)#logging synchronous

Step 5.      Configure vty lines on R1.

Configure a vty line password of ciscovtypa55 and enable login. Set the exec-timeout to log out after 5 minutes of inactivity. Set the login authentication to use the default AAA list to be defined later.

Note: The vty lines on R3 will be configured for SSH in a later task.

R1(config)#line vty 0 4

R1(config-line)#exec-timeout 5

R1(config-line)#password ciscovtypa 55

R1(config-line)#login

R1(config-line)#login authentication default

Step 6.      Configure login banner on R1 and R3.

Configure a warning to unauthorized users with a message-of-the-day (MOTD) banner that says: “No Unauthorized Access!”

R1(config)#banner motd "No Unauthorized Access!"

Task 3:      Configure Local Authentication on R1 and R3

Step 1.      Configure the local user database.

Create a local user account of Admin01 with a secret password ofAdmin01pa55.

Step 2.      Enable AAA services.

Step 3.      Implement AAA services using the local database.

Create the default login authentication method list using local authentication with no backup method.

R1(config)#username Admin01 secret Admin01pa55

R1(config)#aaa new-model

R1(config)#aaa authentication login default local none

Task 4:      Configure NTP

Step 1.      Enable NTP authentication on PC-A.

On PC-A, choose the Config tab, and then the NTP button. SelectOn for NTP service. Enable authentication and enter a Key of 1and a password of ciscontppa55.

Step 2.      Configure R1 as an NTP Client.

Configure NTP authentication Key 1 with a password ofciscontppa55. Configure R1 to synchronize with the NTP server and authenticate using Key 1.

Step 3.      Configure routers to update hardware clock.

Configure routers to periodically update the hardware clock with the time learned from NTP.

R1(config)#ntp trusted-key 1

R1(config)#ntp server 192.168.1.5 key 1

R1(config)#ntp authentication-key 1 md5 ciscontppa55

R1(config)#ntp update-calendar

R1(config)#ntp authenticate

Task 5:      Configure R1 as Syslog Client

Step 1.      Configure R1 to timestamp log messages.

Configure timestamp service for logging on the routers.

Step 2.      Configure R1 to log messages to the syslog server.

Configure the routers to identify the remote host (syslog server) that will receive logging messages.

You should see a console message similar to the following:

SYS-6-LOGGINGHOST_STARTSTOP: Logging to host 192.168.1.6 port 514 started – CLI initiated

R1(config)#logging on

R1(config)#service timestamps log datetime msec

R1(config)#logging 192.168.1.6

Step 3.      Check for syslog messages on PC-B.

On R1, exit config mode to generate a syslog message. Open the syslog server on PC-B to view the message sent from R1. You should see a message similar to the following on the syslog server:

%SYS-5-CONFIG_I: Configured from console by console

Task 6:      Secure Router Against Login Attacks

Step 1.      Log unsuccessful login attempts to R1.

 

R1(config)#login on-failure log

 

Step 2.      Telnet to R1 from PC-A.

Telnet from PC-A to R1 and provide the username Admin01 and password Admin01pa55. The Telnet should be successful.

Step 3.      Telnet to R1 from PC-A and check syslog messages on the syslog server.

Exit from the current Telnet session and Telnet again to R1 using the username of baduser and any password. Check the syslog server on PC-B. You should see an error message similar to the following that is generated by the failed login attempt.

SEC_LOGIN-4-LOGIN_FAILED:Login failed [user:baduser] [Source:192.168.1.5]

[localport:23] [Reason:Invalid login] at 15:01:23 UTC Wed June 17 2009

Task 7:      Configure SSH on R3

Step 1.      Configure a domain name.

Configure a domain name of ccnasecurity.com on R3.

R3(config)#ip domain name ccnasecurity.com

Step 2.      Configure the incoming vty lines on R3.

Use the local user accounts for mandatory login and validation and accept only SSH connections.

R3(config)#line vty 0 4

R3(config-line)#login authentication default

R3(config-line)#transport input ssh

Step 3.      Configure RSA encryption key pair for R3.

Any existing RSA key pairs should be erased on the router. If there are no keys currently configured a message will be displayed indicating this. Configure the RSA keys with a modulus of 1024.

Step 4.      Configure SSH timeouts and authentication parameters.

Set the SSH timeout to 90 seconds, the number of authentication retries to 2, and the version to 2.

R3(config)#crypto key generate rsa

The name for the keys will be: R3.ccnasecurity.com

Choose the size of the key modulus in the range of 360 to 2048 for your

General Purpose Keys. Choosing a key modulus greater than 512 may take

a few minutes.

How many bits in the modulus [512]: 1024

% Generating 1024 bit RSA keys, keys will be non-exportable…[OK]

R3(config)#ip ssh time-out 90

R3(config)#ip ssh authentication-retries 2

R3(config)#ip ssh version 2

Task 8:      Configure CBAC on R1

Step 1.      Configure a named IP ACL.

Create an IP ACL named OUT-IN to block all traffic originating from the outside network.

Apply the access list to incoming traffic on interface Serial 0/0/0.

R1(config)#ip access-list extended OUT-IN

R1(config-ext-nacl)#deny ip any any

R1(config)#int s0/0/0

R1(config-if)#ip access-group OUT-IN

Step 2.      Step 3. Confirm that traffic entering interface Serial 0/0/0 is dropped.

From the PC-A command prompt, ping PC-C. The ICMP echo replies are blocked by the ACL.

Step 3.      Create an inspection rule to inspect ICMP, Telnet and HTTP traffic.

Create an inspection rule named IN-OUT-IN to inspect ICMP,Telnet and HTTP traffic.

Step 4.      Apply the inspect rule to the outside interface.

Apply the IN-OUT-IN inspection rule to the interface where traffic exits to outside networks.

R1(config)#ip inspect name IN-OUT-IN icmp

R1(config)#ip inspect name IN-OUT-IN telnet

R1(config)#ip inspect name IN-OUT-IN http

R1(config)#int s0/0/0

R1(config-if)#ip inspect IN-OUT-IN out

Step 5.      Test operation of the inspection rule.

From the PC-A command prompt, ping PC-C. The ICMP echo replies should be inspected and allowed through.

Task 9:      Configure ZPF on R3

Step 1.      Test connectivity.

Verify that the internal host can access external resources.

  • From PC-C, test connectivity with ping and Telnet to R2; all should be successful.
  • From R2 ping to PC-C. The pings should be allowed.

Step 2.      Create the firewall zones.

Create an internal zone named IN-ZONE.

Create an external zone named OUT-ZONE.

R3(config)#zone security IN-ZONE

R3(config)#zone security OUT-ZONE

Step 3.      Create an ACL that defines internal traffic.

Create an extended, numbered ACL that permits all IP protocols from the 192.168.3.0/24 source network to any destination. Use101 for the ACL number.

R3(config)#access-list 101 permit ip 192.168.3.0 0.0.0.255 any

Step 4.      Create a class map referencing the internal traffic ACL.

Create a class map named IN-NET-CLASS-MAP to match ACL 101.

R3(config)#class-map type inspect IN-NET-CLASS-MAP

R3(config-cmap)#match access-group 101

Step 5.      Specify firewall policies.

Create a policy map named IN-2-OUT-PMAP to determine what to do with matched traffic.

Specify a class type of inspect and reference class map IN-NET-CLASS-MAP.

Specify the action of inspect for this policy map.

You should see the following console message:

%No specific protocol configured in class IN-NET-CLASS-MAP for inspection. All protocols will be inspected.

Exit to the global config prompt.

R3(config)#policy-map type inspect IN-2-OUT-PMAP

R3(config-pmap)#class type inspect IN-NET-CLASS-MAP

R3(config-pmap-c)#inspect

Step 6.      Apply firewall policies.

Create a zone pair named IN-2-OUT-ZPAIR. Specify the source and destination zones that were created earlier.

Attach a policy map and actions to the zone pair referencing the policy map previously created, IN-2-OUT-PMAP.

Exit to the global config prompt and assign the internal and external interfaces to the security zones.

R3(config)#zone-pair security IN-2-OUT-ZPAIR source IN-ZONE destination OUT-ZONE

R3(config-sec-zone-pair)#service-policy type inspect IN-2-OUT-PMAP

R3(config)#int s0/0/1

R3(config-if)#zone-member security OUT-ZONE

R3(config)#int fa0/1

R3(config-if)#zone-member security IN-ZONE

Step 7.      Test firewall functionality.

Verify that the internal host can still access external resources.

  • From PC-C, test connectivity with ping and Telnet to R2; all should be successful.
  • From R2 ping to PC-C. The pings should now be blocked.

Task 10:   Secure the Switches

Step 1.      Configure an enable secret password on all switches.

Use an enable secret password of ciscoenpa55.

Step 2.      Encrypt plaintext passwords.

S1(config)#enable secret ciscoenpa55

S1(config)#service password-encryption

Step 3.      Configure the console lines on all switches.

Configure a console password of ciscoconpa55 and enable login. Set the exec-timeout to log out after 5 minutes of inactivity. Prevent console messages from interrupting command entry.

S1(config)#line con 0

S1(config-line)#password ciscoconpa55

S1(config-line)#login

S1(config-line)#exec-timeout 5

S1(config-line)#logging synchronous

Step 4.      Configure vty lines on all switches.

Configure a vty line password of ciscovtypa55 and enable login. Set the exec-timeout to log out after 5 minutes of inactivity. Set the basic login parameter.

S1(config)#line vty 0 15

S1(config-line)#password ciscovtypa55

S1(config-line)#login

S1(config-line)#exec-timeout 5

Step 5.      Secure trunk ports on S1 and S2.

Configure port Fa0/1 on S1 as a trunk port.

Configure port Fa0/1 on S2 as a trunk port.

Verify that S1 port Fa0/1 is in trunking mode.

Set the native VLAN on S1 and S2 trunk ports to an unused VLAN 99.

Set the trunk ports on S1 and S2 so that they do not negotiate by turning off the generation of DTP frames.

Enable storm control for broadcasts on the S1 and S2 trunk portswith a 50 percent rising suppression level.

S1(config)#int fa0/1

S1(config-if)#switchport mode trunk

S1(config-if)#switchport native vlan 99

S1(config-if)#switchport nonegotiate

S1(config-if)#storm-control broadcast level 50

Step 6.      Secure access ports.

Disable trunking on S1, S2 and S3 access ports.

Enable PortFast on S1, S2, and S3 access ports.

Enable BPDU guard on the switch ports previously configured as access only.

Enable basic default port security on all end-user access ports that are in use. Use the sticky option. Re-enable each access port to which port security was applied.

Disable any ports not being used on each switch.

S1(config)#int range fa0/2-4

S1(config-if-range)#sh

S1(config)#int r fa0/7-24

S1(config-if-range)#sh

S1(config)#int r gig1/1-2

S1(config-if-range)#sh

S1(config)#int fa0/6

S1(config-if)#switchport mode access

S1(config-if)#switchport port-security

S1(config-if)#switchport port-security mac-address sticky

S1(config-if)#spanning-tree portfast

S1(config-if)#spanning-tree bpduguard enable

Task 11:   Verification

Step 1.      Test SSH configuration.

Attempt to connect to R3 via Telnet from PC-C.

From PC-C, enter the command to connect to R3 via Telnet at IP address 192.168.3.1.

This connection should fail, since R3 has been configured to accept only SSH connections on the virtual terminal lines.

From PC-C, enter the ssh –l Admin01 192.168.3.1 command to connect to R3 via SSH.

When prompted for the password, enter the passwordAdmin01pa55 configured for the local administrator.

Use the show ip ssh command to see the configured settings.

Step 2.      Verify timestamps, NTP status for R1 and PC-A.

Step 3.      Test CBAC firewall on R1.

  • Ping from PC-A to R2 at 10.2.2.2 (should succeed).
  • Telnet from PC-A to R2 10.2.2.2 (should succeed).
  • Ping from R2 to PC-A at 192.168.1.3 (should fail).

Step 4.      Test ZPF firewall on R3.

  • Ping from PC-C to R2 at 10.2.2.2 (should succeed).
  • Telnet from PC-C to R2 at 10.2.2.2 (should succeed).
  • Ping from R2 to PC-C at 192.168.3.5 (should fail).
  • Telnet from R2 to R3 at 10.2.2.1 (should fail – only SSH is allowed).

Step 5.      Verify port security.

On S2, use the show run command to confirm that S2 has added a sticky MAC address for Fa0/18. This should be the MAC address of PC-B. Record the MAC address for later use.

Select PC-B. Go to the Config tab. Select FastEthernetunder the Interface section. Edit the MAC address field.

This should cause a port security violation and S2 should shut down port Fa0/18.

Use the show interface Fa0/18 command to view the status of the port. The port should be in the err-disabled state.

On PC-B, go to the Config tab. Select FastEthernet under the Interface section. Change the MAC address to another address.

From interface configuration mode on switch S2 for Fa0/18, use the no switchport port-security mac-address stickyaddress command to remove the original PC-B learned address.

Shutdown and then re-enable the Fa0/18 interface.

On S2, use the show run command to confirm that the port comes up and that the new MAC address has been learned.

Note: If it is desired to reconnect the PC with the original MAC address, you can simply change the MAC address on the PC back to the original one and issue the shutdown andno shut down commands on port Fa0/18. If the PC or a NIC is being replaced and will have a new MAC address, you must first remove the old learned address.

Step 6.      Check results.

Your completion percentage should be 100%. Click Check Results to see feedback and verification of which required components have been completed.

About these ads

About Luís

a fan of Luís Nazário de Lima
This entry was posted in ccna and tagged , , , , , , . Bookmark the permalink.

2 Responses to CCNA Security: chapter 9 Secure Network packet tracer activity – answer

  1. Henryk says:

    Very usefull. What about chapter 10. ASA it is a chalange.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s